Join us on Discord! We now have an official Discord server for OpenFLIXR: , these forums will continue to operate as normal.

Jackett stops running

I've been using openflixr for a while now, and the one thing that seems to keep breaking on me is Jackett.  I only have a handfull (around 5) trackers added, but it seems like once a week or so jackett dies and I have to reboot openflixr to get it up and running again.  Not a huge deal, just a little odd.  This time it's still not coming up though.  Monit says that the connection failed, and I get a 502 when trying to access it through nginx.  Where can I got to get the log file for it to see if I can figure out what's going on?



  • Yes, jackett dies during it's auto-update. I mentioned this in another thread just recently.
    Disable the auto-update inside the app, the script updates it for you.
  • PS logs are here: /opt/jackett/log*.txt
  • Is there a way to disable the auto-update without having access to the webui?  I'm in a catch 22, the site won't launch so I can disable it so it won't launch... yeah..

    I'm assuming that it's in a config file in the /opt/jackett folder (thanks for pointing me there jeremywho) but they seem to be xml based, and I don't see a enable/disable value for it.

    Alternatively, you mentioned in your previous post that you could use the --no-update flag, how exactly would I use that?  I tried the exe alone (seems like it needs mono) so I tried with mono but still was having issues.
  • The only way that I know is the flag for the executable: --NoUpdates
    You'll need to edit the service definition and restart it (webmin is easiest for that)

  • edited August 2018
    So I went in and modified it to the following (added the --NoUpdates option as shown in the spoiler)

    [Unit] Description=Jackett Daemon [Service] User=root Restart=always RestartSec=5 Type=simple ExecStart=/usr/bin/mono --debug /opt/jackett/JackettConsole.exe --NoUpdates TimeoutStopSec=20 StandardOutput=null StandardError=null [Install]

    I also tried --No-Updates, --NoUpdate and --No-Update. Is there an easy way to blow it out and reinstall it? I'm ok with setting it back up again, i'd just really like it to work. Oh, and if it matters i'm seeing

    Aug 11 01:44:13 openflixr systemd[1]: Stopped Jackett Daemon.

    When I run
    journalctl -fa -n 100 -u jackett
    To see what the status is.

  • I might be confusing this thread with another one.  Remind me what the actual issue is?  The original post isn't entirely clear - I thought jackett was stopping like once a week, but your latest post kinda indicates it won't run at all?

    To check the actual status (rather than assume everything is in the journal) use `systemctl status jackett`.
    The journal will give you the history yes, but it doesn't display the status it infers the status.

    Running `mono /opt/jackett/JackettConsole.exe --help` shows you what the command line options are.
    I'm assuming you want to remove & reinstall coz you can't get it to run at all.  If so, try disabling the Monit monitoring of jackett - it'll be attempting restart all the time, which presumably is chewing up the port so you can't start it when you try.  That'll help troubleshooting IMHO.

    If the port is in use, either jackett is starting & using the port then dying, or something else is using the port.

    To monitor what is using the port, add a 'c' to the netstat command so it refreshes every second:
    `sudo netstat -antpc | grep :9117`

    You might need two terminal windows; one to watch the netstat output, another to launch jackett.

    Then again, this might be all wrong if I've misunderstood the issue...
  • So originally the issue only presented itself every week or so, and was resolved by restarting.  Recently it failed completely and would not come back up.

    When I checked the status via systemctl it says

    openflixr@openflixr:~$ systemctl status jackett
    ● jackett.service - Jackett Daemon
       Loaded: loaded (/etc/systemd/system/jackett.service; enabled; vendor preset: enabled)
       Active: inactive (dead) (Result: exit-code) since Fri 2018-08-10 04:58:19 CEST; 2 days ago
     Main PID: 4591 (code=exited, status=1/FAILURE)

    Aug 12 07:10:53 openflixr systemd[1]: Stopped Jackett Daemon.
    Aug 12 07:14:25 openflixr systemd[1]: Stopped Jackett Daemon.
    Aug 12 07:17:58 openflixr systemd[1]: Stopped Jackett Daemon.
    Aug 12 07:21:30 openflixr systemd[1]: Stopped Jackett Daemon.
    Aug 12 07:25:03 openflixr systemd[1]: Stopped Jackett Daemon.
    Aug 12 07:28:35 openflixr systemd[1]: Stopped Jackett Daemon.
    Aug 12 07:32:08 openflixr systemd[1]: Stopped Jackett Daemon.
    Aug 12 07:35:40 openflixr systemd[1]: Stopped Jackett Daemon.
    Aug 12 07:39:12 openflixr systemd[1]: Stopped Jackett Daemon.
    Aug 12 07:42:45 openflixr systemd[1]: Stopped Jackett Daemon.

    I think I may actually have an issue with mono though, as i'm attempting to run the jackettconsole.exe --help but I get a strange error.

    I'd think if it was a problem with mono I'd be seeing other issues as well though.  So possibly just with Jackett.

  • Wow that barfed ugly lol
    Only the top 3-4 lines are needed for a stack trace like this and a quick google suggests you've hit an old (Feb/March) bug.  I'm guessing that Jackett has literally been failing to update and you've now somehow got one of the supporting libraries updated (NLog).

    Manually update Jackett and see if that helps? Copy and paste the below into an ssh session:
    Make sure not to miss the first two lines! You *must* be root and you must be in /tmp.
    sudo su -
    cd /tmp
    #clean out any previous crud rm Jackett.Binaries.Mono.tar.gz*
    #download and unpack wget
    tar -xvf Jackett*
    #actual "install" is just copying from /tmp to /opt/jackett sudo cp -r -u Jackett*/* /opt/jackett/
    rm -rf Jackett*/
    rm Jackett.Binaries.Mono.tar.gz* # Should be good to try running now mono /opt/jackett/JackettConsole.exe --version

    After this you might need to fix the permissions on the /opt/jackett directory, depends a little on your setup.
    By default Jackett runs as root, and gives you a warning as such normally.  My setup I've tweaked to run as openflixr.  If you've changed it I think you'd know.

    I can see how this has maybe happened - when I suggested new update code for jackett in the weekly script, it relies on being able to run mono + jackett enough to get the version. So if you managed to get the NLog (or any other) library update that broke Mono or jackett, jackett would (a) no longer run and (b) fail to update... sorry!

  • edited August 2018
    You should see this or similar in /var/log/updatewkly.log, would be cool if you could confirm (or grab it for me if it's different)

    latestver = v0.9.41
    currentver =
    scripts/ 58: [: !=: unexpected operator
    Jackett is up to date

  • Ok, so reinstalling it resolved the issue.

    I disabled the monit monitoring of jackett
    Downloaded the latest release from the jackett repo at
    Backed up the non working copy of jackett
    Stuck the latest version in /opt/jackett
    Re-enabled monit monitoring of jackett
    Started the service

    Strange that it had that problem, but oh well.  We're good to go now.

    Thank you so much for all your help.

  • Sorry, I didn't see your message before I posted.

    So, because i'm not totally comfortable with linux (I know enough to break stuff, but I know i'll break stuff so I tend to leave it be when possible) here's what I wound up doing.

    Downloaded the latest release
    Unzipped it on my windows box
    used winscp to copy it over to my home folder
    In an ssh session moved the current jackett folder to jackett.old and moved the new download to /opt/jackett

    It still had my prior settings in there, so I'm guessing it's pulling the config file from somewhere in my home folder.  I don't seem to be getting the error message about running as root anymore.  One last thing though that is a bit odd, I have to put in the port now.  My guess is that it's something with nginx needing to be reconfigured, but i'm not sure.  It has the default port still (9117) and once I put that into the url the page comes up just fine.

    Thank you again for helping me out with this to make openflixr better.
  • edited August 2018
    No worries. And a good result regardless, as it exposed a bug that could easily affect others.

    FYI to download things on linux, wget does the trick. Have a look at my code snippet above, you'll see the wget command and it should match the actual url you clicked on (well, you got there later and got a v0.10 version) but it saves having to scp stuff over :smile:

  • Yeah, I remembered wget, it's gonna sound dumb though.... it's always the unzipping/untarring of archives that gets me, I can never remember which switches to use. I just wanted to see if I could get it fixed so I unzipped in windows and then moved it over.  Yeah... not my proudest moment. haha
  • Haha same I always go and Google it lol
  • Thanks Jeremy, will merge in 2.7
  • Looks like there is also bugs in Jackett contributing to this behaviour. And another that bug that will break the weekly update script by launching Jackett instead of just printing the version string.

    So this might all break this weekend :/
  • Fixed in OpenFLIXR 2.7
Sign In or Register to comment.