Join us on Discord! We now have an official Discord server for OpenFLIXR: https://discord.gg/PcCErTQ , these forums will continue to operate as normal.

Pi-Hole DNS Fails to Start - Solution

Hi Folks,

My system was having issues after the update script finished and piihole-FTL (DNS) would not start. After much research I was pointed to trying the latest init script. That fixed it for me.

It's here: https://raw.githubusercontent.com/pi-hole/pi-hole/master/advanced/Templates/pihole-FTL.service

Replace the current one in /etc/init.d/

Run

sudosystemctldaemon-reload

sudosystemctldisablepihole-FTL.service

sudosystemctlenablepihole-FTL.service

sudosytemctlstartpihole-FTL.service

That should get it working again.

You may need to override /etc/resolv.conf initially to reach anywhere external. Restore it after you fix the service.

Tagged:

Comments

  • Do you mind me asking how I do that? I can ping ip addresses but not names, so I can't complete setup. I checked and dnsmasq is indeed not active. I'm just not sure how to replace the script in the VM. Thanks.

  • I did the following:

    in the SSH session,

    sudo vi /etc/resolv.conf

    changed the dns to a good one ( 208.67.222.222 )

    sudo curl https://raw.githubusercontent.com/pi-hole/pi-hole/master/advanced/Templates/pihole-FTL.service -o /etc/init.d/pihole-FTL.service

    sudo systemctl daemon-reload

    sudo systemctl disable pihole-FTL.service

    sudo systemctl enable pihole-FTL.service

    sudo systemctl start pihole-FTL.service


    This completed what was mentioned above.

Sign In or Register to comment.