Join us on Discord! We now have an official Discord server for OpenFLIXR: https://discord.gg/PcCErTQ , these forums will continue to operate as normal.

NZBGet and openmediavault permissions

I'm setting this up for the first time, and using openmediavault as the location for the storage. I am having an issue when trying to download files from Sonarr. I haven't yet tried setting up Radarr or anything else yet, but imagine I will have the same problem with those. I get an error after it tried to download the NZB file that it failed to add the NZB. I then go to NZBGet and see an error "Could not create file /mnt/downloads/temp/nzb..."

I suspect the issue is that openmediavault is not authenticating NZBGet, and therefore doesn't have access to write to the download directory. The problem is, I have no clue what account nzbget is trying to use to authenticate with the storage, nor do I know what the password is that it's using.

Any chance anyone has a similar setup and can shed some light on my issue?

Comments

  • For any that run into this issue, I wound up mounting it as a NFS share instead of CIFS and now it's working.

Sign In or Register to comment.