Join us on Discord! We now have an official Discord server for OpenFLIXR: https://discord.gg/PcCErTQ , these forums will continue to operate as normal.

Installation issues on Hyper-V

Hi, I tried now for 2 days to somehow install openflixr in Hyper-V, but there seems always be some kind of problem. I tried it now in several combinations to get it to run.

Oh and I am a Linux noob, so if I made a step wrong please tell me, as the chances are rather high :)

  • at the beginning I convert the vhd into a vhdx. I was being told it has a little better performance.
  • after the initial boot of the official hyperv image is to let it wait until there seems to be no HDD and CPU usage anymore
  • change the keyboard layout to German (as my keyboard is German :D ) with:
dpkg-reconfigure keyboard-configuration
service keyboard-setup restart
  • run "sudo updateopenflixr"

And there the issues are starting. It seems that it is in an update loop as it tries to install java8, which can't be found and there is an 404 error at the download. I canceled it with CTRL+C after 30 minutes of looping.

I also tried to manual update it with apk-get update and upgrade, it did not help and even threw more errors. At first I ignored it and run the setup, it crashed always at step 8 I think without any more information of why it crashed or maybe if it's done doing the setup. I didn't knew that there was a progress bar later so I proceeded with the web-part and started mounting my NAS etc. There the issues started to accumulate, as it got 403 errors and other stuff in the main site of openflixr. Ok, I stated from scratch again and thought that the culprit maybe is java.

Tried to fix the java issue by myself, removed the old java8 and the repository for apk and installed the latest one.

So far so good, started again the updater, could not remember if there were any issues, as I was long away from the machine. Logged again in and started the console setup. proceeded as usual and suddenly I saw a purple progress bar which was counting the time up. Never saw that before and I thought "okay...maybe it is configuring something, although the CPU and HDD usage is low" and I waited. It stopped after I think 15 minutes with an error and linked to your troubleshooting page. I created the logs as mentioned in the link, but to be honest, the logs are not that great. I uploaded them anyways, maybe you can do with it more :D

Ok I can't upload it, it throw an Error 400 in the editor, alternative:

https://pastebin.com/p3HirBZS

https://pastebin.com/VDGJ2g9a


My question is now, what is the official way of installing it and how does a successful installation process look like? I could not find any videos or even tutorials of openflixr of how to install the newer version. It would help (at least me :) ) to see at what step I am either doing something wrong or something is failing. I do not know if the purple loading bar is doing anything as I only triggered it once.


Is openflixr even supported on Hyper-V? Has someone got it to work on a Server 2012 R2 Hyper-V and are there some extra steps needed for that hypervisor?


Oh and the hardware specs for the VM are:

  • all 4 cores (Intel i5 2500)
  • 8196 MB RAM (though using dynamic RAM from 512-8196 so save some of the RAM)
  • An unfortunate slow cheap consumer HDD, as it is a rather old host system. I also tried it running from an USB 3 flash drive to increase the IOP (poor version of a SSD :( ) as I thought that maybe the HDD is too slow and the services are not getting started fast enough.

I hope this is enough to start with it and experiment a little.

tl;dr: What is the proper way to initial start, setup and run openflixr?


Thanks and I am looking forward to replace my actual non virtualized plex server with your solution :D

Comments

  • I found that document: https://docs.google.com/document/d/1mVkzjBIXyjTIAvDfVrgBZxoHUBtz-N9_Q6CWjhIMqc4/edit

    Is this the actual official way to get it to work, and even then sickrage, monit and Vi are breaking?

  • Anyone here, or any tipps for setting it up ._.?

  • edited April 23

    Sorry, I don't check the forums that often and the other guys (@mediajunkie and @jeremywho) that know more about than I are currently away...

    Though I think this has possibly already been handled on Discord, I want to drop info here for the rest of the class.

    1) Don't use that document. That was from before when the Web setup was broken and before I wrote the setup script. It's a good reference to have around for those inquisitive minds but shouldn't be used as a means to set up. For proper setup, etc., check out this that I pulled together in the last few days: https://github.com/openflixr/Docs/wiki/Setup#getting-set-up

    3) The logs that you uploaded are actually very helpful to us for troubleshooting. The first one shows that the setup didn't find what it needed to proceed (I could make the message a little more user-friendly), which is a few things, but it looks like your VM was running an update at the time and blocking the setup from continuing. The second one tells you exactly what to do and wasn't an error which is what got you to the first log since you ran it again.

    4) OpenFLIXR does support Hyper-V but some have had issues here or there but I can't remember if there was anything consistent and I don't believe it has anything to do with the issues you are having. When I search on Discord for "Hyper-V" there seem to be a number of people who use it and I would assume have it working on Hyper-V now.

    5) I saw your comment on another post here. That is likely because Sonarr isn't up-to-date and can't update. I have a fix in my dev version of the setup script that should resolve that and hopefully will get it pushed up soon once I've been able to test.

    With all that said, if this wasn't already handled on Discord and you aren't up-and-running, do the following:

    1) run the update again which should finish rather quickly this time

    2) run the setup which will tell you to update it and run again because I've made updates.

    If you are still having issues at that point, jump on the Discord Server (link at the top) and we can figure it out from there.

    Note that you might need to start from the beginning following the steps I linked above as there are some nuances that are very important to getting OpenFLIXR to work correctly.

  • Hiya. Don't convert to vhdx, that is your #1 issue. You need to run as-is, complete with old IDE controller for the boot disk.

    Wait for ~15 minutes after first boot to let the original v2.0 updater complete it's update. You need to check that *all* updater processes have finished before manually running `sudo updateopenflixr`. Search the discord channel for how to do that. And aiming I'm still doing things in the correct order, don't run `sudo setupopenflixr` until you're fully updated (ie running Ubuntu v18.04)

Sign In or Register to comment.