Join us on Discord! We now have an official Discord server for OpenFLIXR: , these forums will continue to operate as normal.

Unable to run the docker service after the update

Hi there,

I have been getting great use out of openflixr, particularly with organizr installed in docker. Sadly since the latest update I've been unable to get docker to start.

If I check the status I get:

openflixr@openflixr:/opt/sickrage$ systemctl status docker

● docker.service - Docker Application Container Engine

  Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)

  Active: inactive (dead) since Wed 2019-03-06 19:25:29 CET; 25min ago


 Process: 7612 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock

 Main PID: 7612 (code=killed, signal=TERM)

Any time I try to start the docker service I get:

Job for docker.service canceled.

For a little background I am running this in a VM and worked seamlessly until the update


  • Hope someone else can have a look as I'm quite busy with 2.9, but what does systemctl status docker.service say?

  • Thanks :) It looks the same as above:

    openflixr@openflixr:/opt/sickrage$ systemctl status docker.service

    ● docker.service - Docker Application Container Engine

      Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)

      Active: inactive (dead) since Wed 2019-03-06 19:54:04 CET; 2h 11min ago


     Process: 10519 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock

     Main PID: 10519 (code=killed, signal=TERM)

    Mar 06 19:54:03 openflixr systemd[1]: Starting Docker Application Container Engine...

    Mar 06 19:54:04 openflixr systemd[1]: Stopped Docker Application Container Engine.

  • Sorry I know nothing about docker :(

    But check the basics:

    What user account is docker running as?

    Does that user have rw access to all the files and directories it needs?

    Where does docker log to? what do those logs say?

  • I am a bit of a novice when it comes to linux I'm afraid. I did briefly think it would be quicker to set up from scratch however if i try that sudo updateopenflixr just goes into a loop when it gets to nginx. I have been wrestling with this one for a couple of days now. I notice that the containerd service is also stopped. could you provide me with a couple of commands so i can answer the above?

  • edited March 7

    The loop in the updateopenflixr script is caused by the nginx "bug" - the config file needs to be fixed before the nginx package gets updated, and that's proving difficult to do. Check this:

    Not sure about the other stuff, I'm not much above a novice myself. I had a look at my config file and it gives no clues.

  • I did a little more digging and I think it is because docker works with containerd and the status of this one is:

    containerd.service: Main process exited, code=exited, status=2/INVALIDARGUMENT

    containerd.service: Unit entered failed state.

    containerd.service: Failed with result 'exit-code'.

    I also found a file hiding in the docker folder /etc/docker/ called

    "ystemd[1]: containerd.service: Unit entered failed state."

    Note: The file is not called systemd[1]etc

    I thought I might try changing the folder name to docker2 then moving the key.json back to a folder called docker. Sadly that didn't help either, I still get the above error from containerd

    I have also run journalctl -u containerd and can see:

    Mar 09 15:29:00 openflixr containerd[975]: panic: invalid page type: 5: 10

    I have renamed the moby folder in /var/lib/containerd/io.containerd.runtime.v1.linuxopenflixr but that hasn't helped

    I have renamed the docker folder in /var/lib/ in case there were corrupted files but that hasn't helped. I have tried uninstallation of docker and reinstallation, I still see the above. Little help?

  • After further digging I found that there was a corrupt database file at


    I've renamed it and rebooted, docker now starts but I've lost portainer or at least it's no longer running.

  • So it seems I can run portainer by running:

    sudo docker run -d -p 9000:9000 --name portainer --restart always -v /var/run/docker.sock:/var/run/docker.sock -v /var/lib/docker/volumes/portainer_data portainer/portainer --no-auth

    However I cannot configure portainer or define endpoints as the interface that loads is read only and not connected to an endpoint

    Any help?

  • Join us on the discord channel, the support is a lot more responsive there

Sign In or Register to comment.