Join us on Discord! We now have an official Discord server for OpenFLIXR: , these forums will continue to operate as normal.

OpenFLIXR Setup Shell Script

I put this together in hopes that it will help others while the wizard is disabled.
I've tested as much as I can today but would appreciate others helping out as well! Please provide any feedback through this thread or submitting a Pull Request to the repo.

Thanks to @jeremywho for the awesome gDoc that guided me through my setup and I originally based this on. That post can be found here:
Thanks to @mediajunkie for all the work put into this and providing WebWizard code on GitHub that allowed me to further enhance my script and make it inline with what the WebWizard does.


  • I've updated this to now be in line with what WebWizard outputs and runs.
  • Thanks @MattyLightCU
    In your opinion is this fully operational? As in, we should now be fully able to drop this script in onto a new machine, and get a working system out of it? 

    I'll link to this thread in the setup doc thread.
  • I used this setup script to install OpenFLIXR a few times this weekend.  Thanks for posting it - this helped a lot!  One of the things I ran into was permissions with the mounted directories.  They had all been created with owner/group set to root and the downloads directory was missing many subdirectories.  Running the /opt/openflixr/createdirs script appears to have fixed the issue (still testing) and created the missing folders with openflixr user and group.
  • Thanks for confirming, @garnett
    Permissions on mount points has always seemed a bit weird to me, the permissions of the original folder aren't always (ever?) inherited so until the mounts are mounted, setting permissions won't fix things (I think?).  Someone mentioned setting the UID and GID in the options part of the fstab entry, I assume that the webmin GUI allows for the same.  (Although I must say I set the permissions myself back when I first set up my box, and have never revisited it.)

    Note that createdirs runs at boot, so if you've not been rebooting your new setups much then things may be missing - and of course that reboot needs to happen after any additional storage and your media mounts are mounted. 
    I can certainly see the potential for a race condition where the createdirs script is run before the mounts have mounted - especially if the storage is network based like NFS (or even worse, CIFS).

    Also note that some of the directories under /mnt/downloads should be owned by root, as it is root that is running the process.  Not all of the openflixr apps have been set up to run as the openflixr user account.

    Cheers again,
  • Thanks for the response.  I had rebooted several times, so it wasn't being updated for some reason.  I only found the script through an answer you had provided to a previous user, but it did fix the problems I was facing at that time. 

    I am still not completely up and running yet though.  I have Radarr running with NZBHydra indexing and SABnzd downloading, but Sonarr is failing to connect to either of those services, so I'm still working through it.  Since I've never setup an instance before this script was released, I can't really comment on whether the issue is related to the script or my setup, but I'll keep after it.
  • Nah it sounds like "normal" setup issues - the script/docs only go so far, there's a level of implied knowledge or required learning curve :) Took me about 6 weeks to get everything running (I changed my mind on downloaders/indexers a few times) and then another 3-4 months to get it stable lol
  • @jeremywho From what I know of the setup, this is mostly ready but not "fully operational". However, I think it will get users most of the way through their initial setup. The biggest improvement right now is handling the file mounting, followed by getting Let's Encrypt working properly. After that, I'm going to look into what else I might be able to do to get it to configure as much as possible and allow someone to be set up in hours instead of days, but TBD.

    @garnett Thanks for trying this out and giving feedback. I'll be able to make some changes based on it and hopefully get it committed in the next few days. Was it easy enough to use and understand? If you have any suggestions for improvement, I welcome hearing what they are!

  • @MattyLightCU It was very easy to use!  Thinking back, I can only recall one other quirk which is a simple fix.  When the script downloads and executes from github, it failed each time because it was looking in a specific directory that didnt exist.  It looks like an absolute path is called out here:


    Since this directory didn't exist, the script would just bomb out.  After creating the 'openflixr_setup'  directory and moving both script files there, the script ran fine.
  • Thanks! I probably created it at some point and forgot to add it to the script. I'll get that change in soon!
  • More updates have been made! 
    • Fixed some dumb things I did and cleaned up the file some
    • Fixed folder setup
    • Added more windows and less command-line outputs for consistency
    • Added a menu to select custom scripts that are supported
    • Abstracted some areas to external files and made them get re-downloaded each run
  • Gents, thanks for the script - I blew away my old (2.1) Openflixr, so without the web setup this greatly helped.

    The only issue I ran into was when it switched to the script, and I think I've tracked down the issue... it's Ombi (perhaps this is a 2.8 issue?).

    As soon as we get to requesting the plexreqapi on line 114... it fails. Essentially, it returns the full HTML of a login page - not an API key. After I played around, I actually hit in my browser, and it gave me a setup choice between Plex and Emby. Chose Plex, logged into my account, and it let me access the admin.

    It still won't give an API key - nor will curl actually post a config change - so I ended up setting the connections manually in the admin UI for Ombi.

    Also, headphones still isn't supported in Ombi 3.x, so that part couldn't be done.

    Other than configuring Ombi, everything worked great!

  • Setup script has been rewritten! However, the new version of the script is only meant to be run against OpenFLIXR 2.9 running on Ubuntu 18.04 which hasn't been released yet but will be soon. Please wait until then to set up OpenFLIXR.

  • Sorry, I forget to look at the forum. As I believe you have figured out but want to put it here for others - Yes! The setup script works against OpenFLIXR 2.9.1.

  • There have been a number of fixes and updates to the script over the last month(-ish) but due to time I haven't been able to keep up with any sort of release notes/changelog... So here is a quick summary of what has been done:

    • New menu that is accessible after first successful run of the setup
    • Log submission (and detection/prompting if there have been no changes since submitting logs)
    • Options to (re)configure only specific parts once the initial setup is complete (Particularly useful if there is a bug or settings change that gets made so you don't have to run the entire setup again)
    • Added steps for selecting applications to enable/disable (doesn't control the install or running of the applications, only configuration)
    • A bunch of fixes for issues that have been found with the script
    • A section of the setup with "Various fixes" to fix things found with the system or permissions
    • Prompt for updating if out-of-date and updating for you if you choose to update.
  • Setup script has been updated. Major changes are:

    • Added fixes reported to get the base system running (redis, mono, php7.3-fpm). These will be applied on first run or you can use the Configuration menu option to apply them after your first successful run
    • Fixed some bugs with password changing
    • Added dependency check since some commands weren't available in some instances
    • Logging and checking Let's Encrypt errors

    Full list of changes can always be found in the commit history of the setupscript repo -

  • Setup script has been updated to accommodate the new upgrade process and various fixes.

    Full list of changes can always be found in the commit history of the setupscript repo -

Sign In or Register to comment.