Join us on Discord! We now have an official Discord server for OpenFLIXR: , these forums will continue to operate as normal.

[SOLVED] Jackett is broken

Not sure why or how, the log spew is awful. Might have something to do with Ombi updating to .Net Framework 2.1 but I doubt it.

I tried to manually update Jackett and it didn't help.

Anyone else?


  • No idea what broke it, but fixed by reinstall.

  • There's a problem with the newest Jackett version that will break the openflixr script.
    I have submitted a bug to Jackett but it's likely to cause all sorts of issues for us this weekend.

  • edited August 2018
    If you see this and want to try to avoid borking things, here's what you need to do:
    1. ssh onto the openflixr box
    2. sudo to root ('sudo su -')
    3. edit the file ('nano /opt/openflixr/')
    4. scroll down to line 53
    5. edit the line that starts "currentver=" - you need to change the bit that says "JackettConsole.exe -v" to say "JackettConsole.exe --version"
    6. save and exit (ctrl-o then y, then ctrl-x)
  • Fixed in OpenFLIXR 2.7
  • edited October 2018
    Two VMs, one operational, one clean install. On clean Jacket is working and changed the --version to avoid future problems. On the operational VM Jackett is broken, won't start. I changed the --version, rebooted the VM. But when launching Jackett I get this (I give you only the few first lines...)

    [openflixr@openflixr ~]# /usr/bin/mono --debug /opt/jackett/JackettConsole.exe
    Unhandled Exception:
    System.TypeInitializationException: The type initializer for 'Jackett.Engine' threw an exception. ---> NLog.NLogConfigurationException: Error when setting property 'Format' on Layout Renderer: ${exception} ---> System.ArgumentException: Object of type 'System.ReadOnlySpan`1[System.Char]' cannot be converted to type 'System.String'.
      at System.RuntimeType.CheckValue (System.Object value, System.Reflection.Binder binder, System.Globalization.CultureInfo culture, System.Reflection.BindingFlags invokeAttr) [0x00071] in <3833a6edf2074b959d3dab898627f0ac>:0 

    I deleted the /opt/jackett folder and copied over the folder from the clean install, chown root:root. Still same error. How can I fix this ?

    Edit: I did a manual install according to "", same error when running "mono /opt/jackett/JackettConsole.exe --version" 

    mono /opt/jackett/JackettConsole.exe --version
    Unhandled Exception:
    System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
    Parameter name: value
      at CommandLine.Text.HelpText.AddLine (System.Text.StringBuilder builder, System.String value, System.Int32 maximumLength) [0x00020] in <a8f20d44a846452b83e01ced3f113eaa>:0 
  • I can tell you that the "--version" edit will be reverted every time that Openflixr runs an update (every Saturday night at midnight).  As to everything else there - I have no idea.  It looks like you've got some broken dependencies based on the fact that it won't launch even the basic version output, but there's no clues there about what dependencies are broken.

    Maybe give us the whole error, lets see if there's any clues in there.
  • Jackett dead again after updatewkly ran overnight.
    The problem is a stale binary that should be removed, but our update script simply copies new files in over.

    My update script will fix it, if run with the "-f" or "--force" flag:

  • Released OpenFLIXR 2.8, can you monitor how Jackett behaves now?
Sign In or Register to comment.