Join us on Discord! We now have an official Discord server for OpenFLIXR: , these forums will continue to operate as normal.

[SOLVED] "Unable to lock the administration..." while updating

edited February 2019 in I'm new to OpenFLIXR
I downloaded the most recent versione of openflixr but, after mounting everything, I cannot continue the setup because the button is greyed out with the message "disabled until next release".
Then if I try to update with "sudo updateopenflixr" on a fresh install it get stuck in a cycle with the message "unable to lock the administration directory  (/var/lib/dpkg/), is another process using it?"
Can somebody help?


  • @mediajunkie this might be one for you. Fresh install having issues.

    Maybe a direct link to a slightly older build might be in order while the wizard is broken?

  • This should be fixed with 2.5.1, but "unable to lock the administration directory  (/var/lib/dpkg/)" is also a valid message when the system is updating while my update is trying to access apt, but it will wait till it's released. 
  • For some reason after following the steps in this thread:
    The "unable to lock...." update loop stopped.
  • I’m investigating. 
  • Found the bug, fixed in OpenFLIXR 2.7
  • edited October 2018
    Hello! Slightly off-topic, but is there an ETA for the Openflixr v2.7 ? I know it is a one-man show and it takes a lot of work, but just a ballpark would be great. Thank you for this awesome collection of tools!
  • Sorry I got nothing -@mediajunkie has been offline for a while now and I've got no update to give at all.
    I don't have access to any of the actual code or repositories so I can't assist.
  • Fixed in 2.8

  • edited February 2019

    Hi @mediajunkie ; I just downloaded the OpenFlixr OVA last night, did a new install, and logged in to run the updateopenflixr command, but I'm still seeing the administration directory error.

    Now this is a new install - I haven't even run setup on it, updating was my first step after the install.

    Is there something I need to do (such as a setup) to get to the 2.8 fix?

    Edit: I ended up running apt's update and clearing the cache, and after another reboot the update worked properly.

  • Shoot, that meant to be Fixed in 2.9. Copy pasted it from another thread with an issue which was fixed in 2.8 :)

  • Hah! I can't imagine everything you need to keep track of for each release (and for every package you include). For what it's worth, I may have been too eager - booting up the new image and trying to update right away. I forgot the wisdom in letting it boot up and sit for a bit, like I did with my original install.

    I'm not sure if the apt update helped or not (or commenting out nginx HTTPS config line), but I'm guessing it was more impatience related.

  • It’s less bad as you imagine, it’s worse than you hope for 🤪

    Not sure if every developer thinks this way but every release I do, I think I have the chicken with the golden eggs, it’s the perfect release, can’t think of anything that could go wrong or missed. Which quickly turns to scrambled eggs.

  • I downloaded a fresh 2.0 image, did sudo updateopenflixr, and waited a while.

    Now I do have fast internet and a fast PC, but it took about 15 minutes of waiting for  "unable to lock the administration directory (/var/lib/dpkg/), is another process using it?" to disappear and had a look behind the curtains to see what happend. It's all legitimate updating, it just takes a while and it will only take more time the older the image gets because of more updates.

    But, I did find another blocking bug which is fixed in 2.9, I don't think anything is wrong with the image or update. I know there should be more error handling but it takes too much time from developing cool stuff.

    So my advice is to just wait, leave it there, if necessary a couple of hours :)

    Especially after the 2.9 release where I truly believe I'm getting close to a stable 3.0 release.

  • I had an existing 2.51 install. After issuing sudo updateopenflixr it got stuck on

    unable to lock the administration directory (/var/lib/dpkg/), is another process using it?"

    I left it overnight and ended up forcing a restart followed by sudo dpkg --configure -a

    and sudo updateopenflixr

    Resolved all issues and now updated to 2.8

Sign In or Register to comment.