Join us on Discord! We now have an official Discord server for OpenFLIXR: , these forums will continue to operate as normal.

[SOLVED] Not giving me an IP address to go to setup.

Hello  everybody today I am trying to setup OpenFlixr and followed all the steps using Virtual box and after letting it run for a little bit I get this address. . Thanks!


  • If you have not seen the "Setup wizard Disabled" announcement. Check the Release Announcements category in this forum.

    I have not tried this with a wifi connection so I will lay out some troubleshooting steps for hard wired ethernet cable.

    Plug in the Host machine to a Router. 
    Check your VM Network settings.
    Virtual box window
     select Desired VM
    click Settings.
    Network> Adapter 1.
    I have it set to Attached to: Bridged Adapter. Name: "My NIC" where "My NIC" is the network interface I have my network cable plugged in.
    Check your Router settings (See Manufacturer Website / Owners manual for router specific details.)
    UPNP is a good option to have turned on.
    Check Attached devices for a device with the MAC address in the picture you uploaded.  
    Assign it a static IP address. (This will save some headache later on when the IP tables refresh and/or after a server reboot)

    Let us know how it went.
  • That almost looks like an IPv6 address but not? Weird.
    The only thing I can think of is that your hypervisor networking isn't right, and instead of bridging (so that your VM is "on the same" network as your host you are rather running is NAT mode (your VM is "behind" your host).

    I have never used virtualbox so not sure how to step you through checking.
  • I am certain that it is issuing your MAC address in place of the IP address.  It has the same number of digits and format as a MAC, and the first 6 are identical to my VM's MAC. I assume these are standard for VirtualBox.
  • Which is just bizarre.
    Maybe change the MAC associated with the virtual adapter.  I seem to recall someone mentioning a need to do that in a recent post (ie last 6 weeks)
  • Any luck figuring this out?  I too am only getting a MAC address for the setup link.  I'm running it in VMWare Workstation.
  • Guys that is due to a grep or awk issue with one of the scripts that sets things up. I'm hoping that this is only going wrong on the little text file that is used to tell you how to connect - your machine should still be reachable you just need to know how to find the IP address yourself.

    So, either:
    Log in and check the address (`ip address`), or
    Figure out the dhcp address assigned from your router

    There is a possibility that this same error has caused the wrong IP address to be written into the pihole configuration file.
    But first things first.
  • New here, but I wanted to add a scenario to this issue.  I've encountered this issue twice during setup on VMWare Workstation 11 with the network defaulting to Bridge.  After shutting the VM down, changing the network adapter to NAT and rebooting, the VM comes up with a valid IP instead of the MAC address.
  • I wonder if the script is looking for a line like "eth0" but in bridge mode the adapter is named something like "en1702".  I've not bothered to find the script so I'm guessing, but if it is relying on grep/awk/cut etc then it's certainly open to faults depending on different hardware setups.

    Weirdly, my machine always gets two addresses on the one adapter - the .10 address I have set manually, and a .146 from the same subnet that it's getting from DHCP.  I've checked a number of times and DHCP is not set anywhere.  Also, manually removing that address causes the box to hang, and it generally takes two attempts to start back up again in that situation.  No idea what's going on there lol
  • Fixed in OpenFLIXR 2.9 when released.

  • Already fixed with a hotfix. You should now get an IP address.

Sign In or Register to comment.