Join us on Discord! We now have an official Discord server for OpenFLIXR: https://discord.gg/PcCErTQ , these forums will continue to operate as normal.

[fixed] Lets Encrypt Expired Certificate

@mediajunkie ;

I've revived an email about my https certificate expiring. Additionally, the URL i'm using returns an error preventing the page from loading. stating invalid date or attacker warning biased on what browser i use.

That said, Is there a way to renew the certificate within openflixr that dosent require completing the setup page process to do that?

I made a snapshot, then tried the setup process to remake a valid certificate, upon completion had a few issues with sabnzbd API key changing and a few other minor restarts of services.

Thanks for any advice here. keep up the good work and excellent support.

Comments

  • edited November 2016
    I noticed an issue with the crontab job that does this. Running the command manually allowed me to see what the issue was and I was able to resolve it quickly. 

    /opt/letsencrypt/letsencrypt-auto renew --standalone --pre-hook "service nginx stop" --post-hook "service nginx start"
    Crontab dumps the output to /var/log/le-renew.log so reviewing that file might shed some light on your issue.
  • Thanks @BrandonG777 ;

    That command resolved the auto renew for letsencrypt. 

    I dumped my log directory to an NFS point i can access, but did not have a log for le-renew.log which could be due to my rolled back snapshot. i will look out for this next renewal though, i made a reminder for it the day the new certificate will expire.

    thanks again.
  • Fixed in 1.6
  • Fixed in released 1.6.0
  • Just an update for this, i got a new expire notice from lets encrypt about my domain certificate expiring. Seeing as i am on 1.6.0, i waited 2 days beyond the certificate end of use date. my certificate never did automatically renew.

    However, going back and running the command:
    /opt/letsencrypt/letsencrypt-auto renew --standalone --pre-hook "service nginx stop" --post-hook "service nginx start"
    As pointed to me before by BrandonG777 worked again with no issues.

  • edited September 2017
    Something about virtualenv not found, which is a pip thing I believe. Have to do more digging on this...

    /opt/letsencrypt/letsencrypt-auto: 864: /opt/letsencrypt/letsencrypt-auto: virtualenv: not found
  • edited September 2017
    This fixed my broken 1.6...

    sudo easy_install virtualenv
  • Alright, cool fix.

    Before, the script did nothing. i ran the virtualenv install shown above, and a few things updated. then ran the script again. i was able to get https working again with 1.6

    now, ill update to 1.7 and then look forward to 2.0 when that drops.

    Thanks @BrandonG777

Sign In or Register to comment.