Join us on Discord! We now have an official Discord server for OpenFLIXR: , these forums will continue to operate as normal.

[SOLVED] ALL USERS -: Lidarr config causing issues

Hi, Lidarr dev here. We are getting hit by around 450k error reports a day from users running OpenFlixr2 due to what appears to be bad configuration settings.

Access to the path "/home/openflixr/.config/Lidarr/config.xml" is denied.

Given Lidarr cannot run without access to config, it causes a boot loop which means Lidarr goes into a boot loop.

I image this has something to do with initial configuration you guys are using. Seems looking at the code for the wizard that Lidarr is setup to use different config root than Sonarr and Radarr for some reason. I put in a PR, but not familiar enough with the Openflixr setup to know if thats the only issue.

Your help is appreciated, as this is flooding our sentry server.


  • Hi qstick

    I'm not 100% sure what's going on there but I have my suspicions.  Permissions on the directory & file should look like this:

    I personally don't use Lidarr, so my Lidarr config should be "as shipped" in this project.  The service is running but I've never opened the app web interface nor configured it.

    I assume that only those that do not use Lidarr would be affected, as the error is an indication that Lidarr is trying to run but can't, right?
    Is there any other explanation for the error message?  Some sort of background housekeeping that has managed to be run as a different user somehow?

    @mediajunkie is it possible for you push an update to the crew that sets permissions on this file?  I imagine that it really needs both chmod and chown as the only explanation I can think of is that the permissions on the directory have reset to root:root as we have occasionally seen with some other systems.

    I imagine that the spam is due to Monit continually attempting to restart Lidarr when it's detected as not running.

    Something like this?
    myuser=$(systemctl cat lidarr | grep User | awk -F '=' '{print $2}')
    mygroup=$(systemctl cat lidarr | grep Group | awk -F '=' '{print $2}')
    chown $myuser:$mygroup /home/openflixr/.config/Lidarr/config.xml
    chmod 777 /home/openflixr/.config/Lidarr/config.xml

  • @jeremywho correct, I would assume this affects those not using Lidarr. Though actively we are only see exceptions from around 25 users, but the constant shutdown and restart is causing quite a few events.

    You are correct, once Lidarr sees that it cannot access the config path, it throws fatal error and shuts down. So its trying to start the application but cannot. It's always occurring during application startup while trying to write the API key to the config file.
  • OK, it's most likely that it's Monit that's starting the app over and over about 5 minutes apart.
    We don't have any way of reaching users other than this forum, but the platform should be auto-updating and therefore we will be able to push out something of a fix.  The update script runs weekly on Saturday nights but first we need @mediajunkie to see this - he's not super active these days and I don't have write access to the git repo.

  • Thanks, let me know if you guys need anything else from us.
  • just a quick update - I haven't heard from @mediajunkie in regards to this

  • Thanks we are still being flooded
  • Also seeing this issue with lidarr being caught in a restarted constantly, I've never used lidarr before.
  • @r3myx626 can you grab a screenshot of the permissions of the /home/openflixr/.config/Lidarr directory?

  • Looks to be a permissions issue as described above
  • @jeremywho ;running "sudo chown openflixr:openflixr /home/openflixr/.config/Lidarr/config.xml" seems to have fixed it for me. Doesn't appear I need to modify the write permissions. No more restarts.

  • Excellent. @mediajunkie we need to run this out in the weekly update script!
  • edited December 2018

    To fix this, run
    sudo chown openflixr:openflixr /home/openflixr/.config/Lidarr/config.xml
    r3myx626 said:
    @jeremywho ;running "sudo chown openflixr:openflixr /home/openflixr/.config/Lidarr/config.xml" seems to have fixed it for me. Doesn't appear I need to modify the write permissions. No more restarts.
  • How do you check if it worked?
  • Just check the lidarr logs - if this problem is in play then you'll see a really gnarly exception thrown just after the lidarr service starts that specifically mentions access denied to the config file:
    [v0.5.0.579] NzbDrone.Core.Configuration.AccessDeniedConfigFileException: Lidarr does not have access to config file: /home/openflixr/.config/Lidarr/config.xml. Please fix permissions ---> System.UnauthorizedAccessException: Access to the path "/home/(removed)/.config/Lidarr/config.xml" is denied.
      at System.IO.FileStream..ctor (System.String path, System.IO.FileMode mode, System.IO.FileAccess access, System.IO.FileShare share, System.Int32 bufferSize, System.Boolean anonymous, System.IO.FileOptions options) <0x7f2b9e1d0290 + 0x00532> in <0f8aeac9d63d4b8aa575761bb4e65b79>:0

  • edited February 2019
    Should be fixed in OpenFLIXR 2.8, released today or tomorrow.
    I'm sinking this thread and mark it resolved, if you guys still have problems after 2.8, please let me know.
Sign In or Register to comment.