We're trying out using Discord. Check the thread for the link. These forums will continue to operate as normal.

Cant get openflixr to work after setup/reboot

edited November 2018 in I'm new to OpenFLIXR
Hey i am new to openflixr but i can't get it to work.
I installed openflixr on a ESXI 6.5 server but everytime when i run the setup the webinterface works and htpc.
When I reboot openflixr my eth0 interface doesn't work. I noticed it gets an error when I try to restart the networking service:

● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
  Drop-In: /run/systemd/generator/networking.service.d
           └─50-insserv.conf-$network.conf
   Active: failed (Result: exit-code) since Sat 2018-11-17 14:54:20 CET; 8s ago
     Docs: man:interfaces(5)
  Process: 5804 ExecStop=/sbin/ifdown -a --read-environment --exclude=lo (code=exited, status=1/FAILURE)
  Process: 6039 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=1/FAILURE)
  Process: 6028 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=
 Main PID: 6039 (code=exited, status=1/FAILURE)

Nov 17 14:54:20 openflixr systemd[1]: Stopped Raise network interfaces.
Nov 17 14:54:20 openflixr systemd[1]: Starting Raise network interfaces...
Nov 17 14:54:20 openflixr sh[6028]: /etc/network/interfaces:8: misplaced option
Nov 17 14:54:20 openflixr sh[6028]: ifquery: couldn't read interfaces file "/etc/network/interfaces"
Nov 17 14:54:20 openflixr ifup[6039]: /etc/network/interfaces:8: misplaced option
Nov 17 14:54:20 openflixr ifup[6039]: /sbin/ifup: couldn't read interfaces file "/etc/network/interfaces"
Nov 17 14:54:20 openflixr systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
Nov 17 14:54:20 openflixr systemd[1]: Failed to start Raise network interfaces.
Nov 17 14:54:20 openflixr systemd[1]: networking.service: Unit entered failed state.
Nov 17 14:54:20 openflixr systemd[1]: networking.service: Failed with result 'exit-code'.

My /etc/network/interfaces file:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo docker0
eth0
veth645948f
vetha16eec4
iface lo inet loopback

# The primary network interface
iface docker0
eth0
veth645948f
vetha16eec4 inet static
address 192.168.0.32
netmask 255.255.255.0

I never worked with docker or veth interfaces before so i have no idea what is wrong with it.
I already commented line 8 out but then it gets a error on line 9 and so on.

I work whole days so i might not respond quick.

Edit 19-11-2018 Adding details:

ESXi 6.0 and later (VM version 11)
Network interface is E1000
    No results for this poll

Comments

  • What version of virtual hardware do you have set (HW v13? or something else?)
    What type of virtual network adapter do you have set in the VM definition?  VMXNet3, or E1000, or something else?
  • jeremywho said:
    What version of virtual hardware do you have set (HW v13? or something else?)
    What type of virtual network adapter do you have set in the VM definition?  VMXNet3, or E1000, or something else?
    ESXi 6.0 and later (VM version 11)
    Network interface is E1000
  • That should work without you needing to do anything.  It's possible either the OVF deployed badly (unlikely) or that the original image is corrupt (quite likely, although we don't know the reason).

    Try VMXNet3 as the adapter type, but otherwise I reckon you'll need to download again and re-deploy.
  • jeremywho said:
    That should work without you needing to do anything.  It's possible either the OVF deployed badly (unlikely) or that the original image is corrupt (quite likely, although we don't know the reason).

    Try VMXNet3 as the adapter type, but otherwise I reckon you'll need to download again and re-deploy.
    I am just seeing your post "Setup Instructions without Web Wizard". seems like if you open the web setup just after the ofv is delpoyed you can still do it but it breaks the server. sorry for bothering you I will just follow your guide. see what happens.
  • oh right, i understand what you've done now.  Still no idea why the network driver wouldn't load though, that's not right/good/intended lol

  • jeremywho said:
    oh right, i understand what you've done now.  Still no idea why the network driver wouldn't load though, that's not right/good/intended lol

    Well I found out the web setup breaks the /etc/network/interfaces file. so when you reboot the system the networking service won't start because the /etc/network/interfaces file is broken.

    I am now updating my openflixr takes a while specially with my slow internet.

    Before I updated I noticed that sickrage wasn't working. I hope updating will fix it.
  • no, because of a problem with the sickrage project.  Not sure if anyone has documented the fix, but it's in the sickrage reddit threads.  I have the steps that can be run manually here.
  • edited November 2018
    Thanks i saw sickchill in your manual setup guide. let me try that :)
  • edited November 2018
    Ok i installed sickchill and it works!
    I only have to manualy configure it and find what works and what not.

    these are my steps:
    console/ssh:
    sudo apt-get update && sudo apt-get install unrar-free git-core openssl libssl-dev python2.7
    sudo mkdir /opt/sickchill
    sudo chown openflixr:openflixr /opt/sickchill
    sudo -u openflixr git clone https://github.com/SickChill/SickChill.git /opt/sickchill
    sudo cp /opt/sickchill/runscripts/init.ubuntu /etc/init.d/sickchill
    sudo chmod +x /etc/init.d/sickchill
    sudo cp /etc/default/sickrage /etc/default/sickchill
    sudo sed -i 's/sickrage/sickchill/g' /etc/default/sickchill
    sudo cp /opt/sickchill/config.ini /opt/sickchill/config.ini.bac
    sudo cp /opt/sickrage/config.ini /opt/sickchill/config.ini
    sudo update-rc.d sickchill defaults
    sudo update-rc.d sickchill enable
    sudo service sickchill start

    In htpc:
    login to htpc
    go to settings then sickrage
    change basepath and reverse proxy link to "/sickchill"
    copy the api key

    nginx + sickrage:
    test if sickrage works with default settings
    go to sickchill "IP_ADDRESS:8081" check if it works
    open ssh or console and edit "/etc/nginx/sites-available/reverse" and "/etc/nginx/sites-enabled/reverse"
    find "location /sickrage" and change it to "location /sickchill" in both files
    now stop sickchill service "sudo service sickchill stop"
    now edit /opt/sickchill/config.ini
    find "web_root = """ and change it to "web_root = "/sickrage""
    find "handle_reverse_proxy = 0" and change it to "handle_reverse_proxy = 1"
    find "api_key = SOME_KEY" and replace the key with the one you copied from htpc
    now start sickshill service again "sudo service sickchill start"
    and go to "IP_ADDRESS/sickchill" check if it works. (IP_ADDRESS:8081 will not work anymore)

    Optional cleaning up/disable sickrage:
    sudo update-rc.d sickrage disable
    sudo update-rc.d -f sickrage remove
    sudo rm /etc/init.d/sickrage
    sudo rm /opt/sickrage -R
  • Can you chuck all that into a how-to thread on it's own?
Sign In or Register to comment.