Join us on Discord! We now have an official Discord server for OpenFLIXR: https://discord.gg/PcCErTQ , these forums will continue to operate as normal.

Clean Install update from 2.0 to 2.5.X "retry" loop

While updating from a clean install of 2.0 to 2.5; the update process gets looped on a retry while attempting to install nginx-light. Gets and exit code of 1 and retry's in a failing loop. scrolls quite fast, but i'm sure that's where it hangs. i can restart the process and get the same result. 

Installed Virtualbox, tested with above result.

Comments

  • I noticed this in another thread:

    MPUop said:
    For some reason after following the steps in this thread: 
     http://www.openflixr.com/forum/discussion/comment/1592/#Comment_1592
    The "unable to lock...." update loop stopped.


  • I’m investigating. 
  • Found the bug, fixed in OpenFLIXR 2.7
  • Thank you sir.
  • When will 2.7 be available? I am stuck on this endless loop as well... 
  • Did you manually fix the nginx config so that it doesn't break on the ssl directive?
  • I did manually fix the reverse file and commented out the ssl and then it did a critical system crash and I had to delete the whole vm slice. I did it twice with the same critical error. Do you comment that line out before you run the sudo updateopenflix?
  • I think my problem is somewhere in the update process. Basically, I open the 2.0 and load it up fresh in Virtual Box. I do not do any config or setup at all, just load it up and log in. As soon as it comes up, I run sudo updateopenflixr. So I think I am doing something wrong in the update or not doing something before updating...
  • It doesn't make any difference whether you comment out that line before or after.
    I don't know what you mean by a critical system crash, but if you mean nginx won't start then you really needed to test the config by running `nginx -t` before moving on.
    If you mean the system somehow ate itself and won't boot, then editing the nginx conf file is not the problem at all.
  • when I commented out the line, it crashed my vm and it won't start... I all happens when it asks me to update the nginx file or keep mine. I always tell it to update it and right after it fails to start with an error. So I go into the reverse file and add the # to the front. save it and reboot. Never boots again after that process...
  • What does the machine console show? Does it go through POST, booting ubuntu and starting services?
    You're going to need to start posting screenshots but at this point it sounds like your VM image is corrupt.
  • I will post a screenshot later. As soon as I double click the image to start the vm, it errors immediately with a critical error warning, and cannot continue booting. Commenting that line out does something to the image that will not let me even boot it. I was just going to wait for the new 2.7 update to come out.
  • 2.7 is unlikely to be a new image, all of the other incremental updates have been scripted updates for working systems.  I'd suggest you download a new copy and re-deploy it, editing a single text file should not impact the ability of the VM to power on.
  • I will download a new one today and try it again. I will post my screenshot of what happens. Everything on the update seems to go well except the nginx. It either fails to start after I let it update the config file, or corrupts the whole image after I comment out the line and start the update again. Very strange... I use ubuntu 16 and have virtual box installed running the openflixr 2.0.
Sign In or Register to comment.